Fixing nextgen gallery after upgrade 1.4.1

Nextgen Gallery is awesome, it displays images in your WordPress installation in a way that is very customizable and using the plugin itself is a breeze.

Recently it got updated to version 1.3.4 3.1.5 1.4.1. If you're using a custom template, this upgrade most likely broke your installation. The reason seems to be that the upgrade removes or overwrites the view directory found under the wp-content/plugins/nextgen-gallery/ folder.

If you use the automatic upgrade feature from WordPress, then you'll need to put back your template from a backup. If you're doing the upgrade manually then just be careful not to overwrite your template and you should be fine. If you're not using custom templates, then this issue probably doesn't affect you.

8 Comments

  1. just upgraded my NextGen gallery and didn’t think about it any more until one of my visitors said my pictures weren’t working.

    When I checked the dashboard the plugin was gone?
    I tried to install it again but got
    ‘Destination folder already exists.

    /domains/deltacephei.nl/public_html/wp-content/plugins/nextgen-gallery/ Plugin Install Failed.’

    How can I fix this? Where are my uploaded pictures? :S Can you help me?

  2. just upgraded my NextGen gallery and didn’t think about it any more until one of my visitors said my pictures weren’t working.

    When I checked the dashboard the plugin was gone?
    I tried to install it again but got
    ‘Destination folder already exists.

    /domains/deltacephei.nl/public_html/wp-content/plugins/nextgen-gallery/ Plugin Install Failed.’

    How can I fix this? Where are my uploaded pictures? :S Can you help me?

  3. Hi Suzanne, its a bummer to hear what you’re going through. I can try helping you.

    What version of WordPress are you using? If you’re using the latests, on your dashboard -> plugins, you could have up to 5 different filtering options: All, Recently Active, Active, Inactive, and Upgrade. If you go to All, and the plugin isn’t there, then I would try to re-install it as you did.

    Since you got the error that the plugin is already there, you should FTP to your plugin directory and look for the nextgen-gallery folder. If it is in fact there, make a backup of it, then remove it. Try the installation again and see if things are better. If you need more help, you can try me at my contact page and I can try to help you.

  4. Hi Suzanne, its a bummer to hear what you’re going through. I can try helping you.

    What version of WordPress are you using? If you’re using the latests, on your dashboard -> plugins, you could have up to 5 different filtering options: All, Recently Active, Active, Inactive, and Upgrade. If you go to All, and the plugin isn’t there, then I would try to re-install it as you did.

    Since you got the error that the plugin is already there, you should FTP to your plugin directory and look for the nextgen-gallery folder. If it is in fact there, make a backup of it, then remove it. Try the installation again and see if things are better. If you need more help, you can try me at my contact page and I can try to help you.

  5. Hey Oscar. Thank you very much for taking the time to post this information. I’ve been making myself crazy for the last 4 days trying to get my nextgen gallery to work. The flash overlay just would not appear, only a small slideshow that was embedded into the small space in my content area.

    I discovered your site via google, because I started to suspect that my testing of wp e-commerce, and then subsequent deleting of it, might have messed something up. Your article confirmed that I should probably delete nextgen completely and do a fresh install. It worked!

    For the past few days, I’ve been adding and adding different plugins: nextgen flashviewer, nextgen smooth player, jwplayer… etc, etc. When, all along, all I needed to do was delete something and start fresh.

    Thanks so much. ps. I like the nice clean look of this blog. The font and white space makes it extremely readable. Very nice.

  6. Hey Oscar. Thank you very much for taking the time to post this information. I’ve been making myself crazy for the last 4 days trying to get my nextgen gallery to work. The flash overlay just would not appear, only a small slideshow that was embedded into the small space in my content area.

    I discovered your site via google, because I started to suspect that my testing of wp e-commerce, and then subsequent deleting of it, might have messed something up. Your article confirmed that I should probably delete nextgen completely and do a fresh install. It worked!

    For the past few days, I’ve been adding and adding different plugins: nextgen flashviewer, nextgen smooth player, jwplayer… etc, etc. When, all along, all I needed to do was delete something and start fresh.

    Thanks so much. ps. I like the nice clean look of this blog. The font and white space makes it extremely readable. Very nice.

  7. Thanks for your compliments, with the time I have, this was the best layout I could come up with for now, I’m glad you liked it.
    As far as your site goes, I’m glad you’ve gotten it all worked out. I like your theme, and dig the snowflake effect!

    Hope to see you around soon and btw, if you need help with WP or plugins feel free to ask.
    – Oscar

  8. Thanks for your compliments, with the time I have, this was the best layout I could come up with for now, I’m glad you liked it.
    As far as your site goes, I’m glad you’ve gotten it all worked out. I like your theme, and dig the snowflake effect!

    Hope to see you around soon and btw, if you need help with WP or plugins feel free to ask.
    – Oscar

Comments are closed.