mod_headers Required when using WP Super Cache

If you're using your own server to run WordPress and you're using the WP Super Cache plugin to help with performance, you might see this warning at the top of your pages in the WordPress Dashboard:

mod_headers - Required to set caching information on supercache pages. IE7 users will see old pages without this module.

Under most circumstances, fixing this warning is very simple. Simply install mod_headers and reload or restart your Apache server.